Troubleshooting Checkmk Upgrade 2.3 → 2.4: “Could not connect to ui-job-scheduler” Error When Activating Changes
After upgrading to Checkmk 2.4 from 2.3, activating changes may fail if local Python modules block the ui-job-scheduler from starting.
LAST TESTED ON CHECKMK 2.4.0P0
Overview
After upgrading Checkmk from version 2.3 to 2.4, the update completes successfully with no reported errors. However, after the upgrade, activating changes in the web interface fails with an error indicating that the ui-job-scheduler service cannot be reached.
Problem
When attempting to activate changes, the following error is displayed:
Could not connect to ui-job-scheduler.
Possibly the service <tt>ui-job-scheduler</tt> is not started, please make sure that all site services are all started.
Tried to connect via <tt>/omd/sites/mysite/tmp/run/ui-job-scheduler.sock</tt>.
Reported error was: HTTPConnectionPool(host='local-ui-job-scheduler', port=80):
Max retries exceeded with url: /start (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f1638ec07a0>:
Failed to establish a new connection: [Errno -2] Name or service not known')). |
The web.log file shows a corresponding traceback similar to the example below:
2025-10-22 17:47:14,045 [40] [cmk.web 6096] Unhandled exception (Crash ID: 60e6af18-af5e-11f0-8e3e-0050568c139b)
Traceback (most recent call last):
File "/omd/sites/mysite/lib/python3/cmk/gui/pages.py", line 102, in handle_page
action_response = self.page()
File "/omd/sites/mysite/lib/python3/cmk/gui/wato/pages/activate_changes.py", line 1013, in page
activation_id = manager.start(
...
cmk.gui.job_scheduler_client.StartupError: Could not connect to ui-job-scheduler.
Possibly the service <tt>ui-job-scheduler</tt> is not started, please make sure that all site services are all started.
Tried to connect via <tt>/omd/sites/mysite/tmp/run/ui-job-scheduler.sock</tt>.
Reported error was: HTTPConnectionPool(host='local-ui-job-scheduler', port=80):
Max retries exceeded with url: /start (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f1638ec07a0>:
Failed to establish a new connection: [Errno -2] Name or service not known')). |
Cause:
This issue has been seen when locally installed Python modules are present under the site’s ~/local/lib/python* path. These can conflict with the updated Python environment in Checkmk 2.4, preventing the ui-job-scheduler from starting correctly.
Solution
Verify all site services are running:
OMD[mysite]:~$ omd statusIf any processes are stopped, restart the site:
OMD[mysite]:~$ omd restartIf all services are running, but the issue persists, check for locally installed Python modules:
OMD[mysite]:~$ find local/lib/python* -name "*info"Remove any locally installed packages from your sites
~/local/lib/python/*directoryOnly remove locally added or custom modules. Do not delete Checkmk core libraries.
Restart the site:
OMD[mysite]:~$ omd restartTry activating changes again in the web interface.
The issue should now be resolved.
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